Problem with topologies

Dear everyone,

Something strange happens when I try to create a topology, either I am doing something wrong or there is a problem with my GPlates software.

The components of my topology (ridges, subduction zones, transforms) completely disappear when I create the topology.
If I understand correctly, the topology should overlie these features instead of replacing them, because you should be able to create multiple topologies using one feature (e.g. two plates with the same ridge).
Making layers visible or invisible does not change anything.

I hope you can help me out,

Jan Westerweel

1 Like

Hi Jan,

This confused me when GPlates 2.2 came out as well! I thought it was broken for a long time but it’s actually just an option which was added in.

Go to Edit -> Preferences -> View, and select Show topological sections.

Hope that helps!



Hi Jan (and Tom),

Yes this was a change made in GPlates 2.2 that makes life easier for most users, but unfortunately creates this issue for power users.

We decided that the majority of GPlates users do not actually build/create topologies, they just load up existing topologies to view them. And they are expecting to see nice closed topological boundaries. However, prior to GPlates 2.2, there would also be these dangling bits hanging off the edges of topologies. So we decided to hide these by default, while providing an option to turn them back on for power users.

First I’ll explain what the dangling bits are. Then I’ll explain the options to turn them back on.

For reference, the following examples use the dynamic polygons (and their associated rotation files) from the GPlates 2.2 sample data (for reasons I’ll state at the end).

Using GPlates 2.1, if you load up the dynamic polygons you would have seen this…

In contrast, using GPlates 2.2 you would see this…

…which hides the dangling bits. These are the ridge/transform/subduction features that form the boundary of a dynamic polygon. In other words, each dynamic polygon has a list of these topological sections. Adjacent sections are intersected with each other all the way around the topological boundary until a (dynamic) polygon is created (for the current reconstruction time). And it’s the intersection process that leaves behind dangling bits.

So now that we have dynamically resolved polygons, most users just want to see those and not their contributing topological sections. GPlates 2.2 does this automatically (as the default) by finding all features used as topological sections by all visible dynamic polygons (and deforming networks) for the current reconstruction time. And then hides them. (I use the terms dynamic polygons and deforming networks interchangeably with topological boundaries and topological networks). Any features not used by topological boundaries/networks are not hidden. So, for example, coastlines are not going to be hidden by this approach.

The option that controls this hiding is the Show Topological Sections check box…

…note that by default it is unchecked. However, if you check it then you’ll get back the GPlates 2.1 behaviour…

One thing to note, this setting is saved by project files (and recent sessions). So if you are currently showing topological sections but then load a project that had them hidden, then while the project is open they will be hidden. However once you close the project or recent session (for example, with File > Clear Session) it will return to the default setting.

If you build topologies frequently, or want topological sections to be visible in general, you can change the default behaviour as Jan pointed out…

…however note that you should restart GPlates 2.2 for this preference to take effect. I would highly recommend all power users do this. But remember that whatever default setting you have, it will get temporarily overridden while a project file (or recent session) is loaded as mentioned above.

You might be wondering, instead of all this, why not just make the green layers invisible…

…there’s two reasons. The first reason is new users would be unaware they need to do this. The second reason is not all topological sections live in the green layers. For example, a topological line lives in a purple layer (because it’s topological). And a topological line can be a topological section of a topological boundary (or network). So it should be hidden also, and so you would make the purple layer invisible, but that would also hide any topological boundaries/networks in that purple layer. So for these two reasons it’s better to use Show Topological Sections and have it be turned off by default, so that this issue is taken care of automatically for most users.

And finally, for these examples, I’ve used the dynamic polygons in the GPlates 2.2 sample data for a reason. This is because turning off Show Topological Sections only hides those features actually referenced by topologies. The dynamic polygons in the GPlates 2.1 sample data had un-referenced features lying around - these were features that were once referenced by the topologies but ended up not getting used. GPlates cannot hide these unused features because it has no clear way of distinguishing them from normal features that are meant to be visible (like coastlines), and so it only hides the referenced features. However the GPlates 2.2 sample data removed all unused features from the topological GPML files prior to release, and so turning off Show Topological Sections works as expected.



Dear Tom and John,

Thank you for your explanations.
Indeed, this was the problem. A simple solution, but something you should know I guess!

Best wishes,