Issue starting GPlates

I’ve been trying to start GPlates on my Windows machine but I keep getting the attached message and it won’t start.

Anyone knows how to fix this? Note that I couldn’t even find the folder in which the log file exists.


Hi Saleh,

It’s basically because your system is using OpenGL 1.1 (instead of OpenGL 2 or above).

Have a look at this post. There’s also this post - but it ends up at the same thing (not having/using OpenGL >= 2.0).

1 Like

Hi @saleh,

Did John’s answer solve your problem?

Hi John,

Thanks a lot for your response and apologies for not getting back sooner; I’ve been distracted by other things I’m working on and had little time trying out the suggested solution.

The issue is now solved. Here is a brief about my experience, which might help others having similar issues. (in hindsight this looks a bit lengthy- apologies)

Thanks to you, your post you shared gave me a idea where to start. Using your lead on upgrading the graphics driver, I checked the graphics drivers using Device Manager → Display Adapters. There were two: an Intel & a Radeon. I’m really a novice when it comes to the ins and outs of computers so I wasn’t sure what each does - still am for the most part. I tried to update both (RC → Update driver) and was told the best drivers for my device are installed.

After further searching I was guided to check graphics options from System → Display-> Graphics. There I saw the apps using the graphics drivers (I think) and GPlates wasn’t there. I added it (Desktop app → Browsed to GPlates folder and selected its icon). When GPlates was added an Options ‘option’ showed up beneath it and there you get to select the Graphics preference. It turns out that only when selecting the Radeon (High performing) option that GPlates launches successfully.

Thanks again for your support and hope this can be of use for others.


Hi @mchin,

Yes, it did thanks for following up and to John for his response. Much appreciated.


Hi Saleh,

Thanks for reporting that, and good job solving that.

It does sound like your integrated Intel graphics is either:

  1. quite old (eg, Intel GMA) and hence doesn’t support OpenGL 2.0, or
  2. there’s something weird happening with its driver (even though it’s reported as the latest).

Switching to your Radeon graphics (which supports OpenGL 2.0) did the trick. Thanks for describing to others how to make the switch for GPlates.

1 Like

You’re welcome John and thanks to you too.