Error while launching GPLATES v2.3.0


I have installed GPlates 2.3 for Windows by using gplates_2.3.0_win64.exe downloaded GPlates download website.

During the installation, there was no errors, but when I opened the GPlates application, I got the errors below in the screenshot atteched .

Could you please help us to reslove this issue ?

Hi salma,

It looks like you’re having the same issue as this post.

Can you try this new build in this folder and see if it changes anything?

I couldn’t figure out why this was happening. And then, after going back through the source code, I realized a change (that should prevent this issue) didn’t make it into the 2.3 release (when I thought it had). So I’d be interested to see how the above build goes (at least it should produce a different error message relating to your installed OpenGL driver, or hopefully just works).

Hello John,

I tried to new, the application launches with the following error ( Screeshot below).

Your help is much appreciated

Hi salma,

Thanks for testing that! It’s giving a different error message, which is good, getting closer to the core issue.

The new error is coming from inside Qt5 (a library used by GPlates). Browsing the source code I think it’s not finding the GL_ARB_shader_objects OpenGL extension.

So it would be very helpful if you could run GLview and see if you have that extension :slight_smile:. For example, this is what I have…

…and expanding GLARB and scrolling down I see the GL_ARB_shader_objects extension…

Even more helpful would be if you could click the button in the following image that exports an XML file and email me that file (might have to zip it up or rename to .txt to avoid it getting removed from the email for security reasons)…


Hi John,

I tried to install GLview to follow the steps you described, but I got this error :

Your help is to much apprecied !

Hi salma,

Try right clicking on the installer and running as administrator.

It looks like it’s having trouble with write permissions. Normally Windows will prompt you to elevate permissions but maybe that’s disabled on your system or just not working for some reason.

Hello John,

I have installed the GLview, and follow up the steps, but I didn’t found the GLARB extention, please see the screenshot below.

Thank you !

Hi salma,

Thanks for that. As I suspected it looks like it’s stuck on an ancient version of OpenGL (1.1). On Windows this basically means there’s no installed OpenGL driver (this is also why it says GDI Generic instead of a specific graphics chip).

By the way, are there other options under Renderer:? Ie, the section in the following image…


And if you send me the following information I can probably tell you which OpenGL drivers to install (also I’m interested to know what systems are having this problem)…

Thanks for your quick feedback,

In the screenshot below you find the option under Renderer:

Also could you please tell me what is you email as I can send you the file you asked for?