GPlates crashes when "Enabling Pole" in "Move Pole" tool

Using gplates 2.2.0 on windows 10 64bit but lower end laptop. I first had the problem with a project open but it seems to happen even if the program is freshly opened. As soon as I click the tickbox the program freezes and I get the blue loading circle around my cursor. About 10 seconds later GPlates closes.
I tried downloading 2.3.0 and had the same issue.

1 Like

Beginning to think our posts will take a while to be noticed, it’s a real pain isn’t it…

We are waiting for John Cannon to come back from leave. He’ll be back tomorrow. Sorry about the delay …


Thats great!!! I just can’t wait to be able to keep using the app lol

1 Like

I think the problem is specific to your data because I’m not having an issue with that tickbox (at least not on Windows or macOS).

Maybe first try the Windows beta.4 here. There was a crash fix after the 2.3 release to do with the Modify Reconstruction Pole tool (but only happens when resetting rotation, using shortcut key, in the middle of mouse drag - so perhaps unlikely to fix your issue).

If that doesn’t work then… if you send me some minimal data (and an outline of the basic steps) that reproduces the issue then I can take a look.


Hi John,
I am unable atm to test your fix as my device is being repaired. However, i cant really tell you how the issue occured anyway, as all i do is click the tickbox on a project, new or old, and the application crashes

The issue persists in the beta. What kind of data do you need me to send? And as Imalilwilde23 stated the issue is the same in a new project with nothing on screen or in an old project. I can replicate it by

  1. opening gplates
  2. pressing 5 to use Pole Manipulation
  3. pressing O to use Move Pole
  4. clicking the checkbox “Enable Pole”
1 Like

Better description than me lol

1 Like

Im gonna guess that he may want a video of some kind. Just to see what happens if he cant replicate it

You have any other ideas?

Thanks, but unfortunately that does not crash for me (using the GPlates 2.3 Windows public release build).

The fact that this happens without first having loaded any data is very unusual. Especially since I’m using the exact same GPlates build with the same dependency DLLs (in same directory as gplates.exe) and observing different behaviour.

It makes me wonder if a different dependency DLL (like qt5) is somehow being used, as mentioned in this post. For example, you may have previously loaded another application (since booting up your computer) that also uses the same qt5 DLL names, but the DLL versions are different, and then GPlates might then use those wrong-version DLLs (due to the statement mentioned in that post: “If a DLL with the same module name is already loaded in memory, the system uses the loaded DLL”).

One option to verify that might be to use DLL redirection. If you’re keen then you could give that a try. I’ve not tried it myself, but essentially it seems to amount to running the Registry Editor application, setting a new registry key, restarting your computer, creating an empty file called gplates.exe.local and placing it in the same directory as gplates.exe (probably easiest to do this with the beta.4 build you tried, so that you don’t need admin privileges).

At the moment I can’t really think of anything else (other than a DLL issue) that could cause this problem.


Hi john,
I want to ask, would having Gplates and all its files on a External Hard Drive be the cause for the DLL isssue? If so, what do i do, as my device has literally no space on the C Drive

I haven’t tried that myself, but I don’t think that would be an issue.

By the way, one way to see what DLLs are being used by GPlates is to follow the first method on this webpage. You should then see that the main DLLs (like Qt5...) are being loaded from the directory containing the GPlates executable. For example, in the following screenshot I’ve circled (in red) the important ones - they should be loaded from the C:\Program Files\GPlates\GPlates 2.3.0\ directory. In fact you should pretty much see the same results as me for all C:\Program Files\GPlates\GPlates 2.3.0 entries. Does that happen for you both?

1 Like

Lets hope that MoonTruther can try this, as my Laptop is being fixed with a new battery.

It may be a few days until its ready to be picked up, idk atm

I tried this and the issue was not fixed sadly.
All the processes you circled are also using the correct new DLL.
Mine are formatted differently though, not C:\Program Files\GPlates\GPlates 2.3.0 but C:\Users(my name)\Desktop\Art.… etc. to the file I open gplates in.

1 Like

Oh boy, thats not good

1 Like

Also, do the processes not circled in red (but still in C:\Program Files\GPlates\GPlates 2.3.0\) show up as C:\Users(my name)\Desktop\Art\… ? I just want to make sure all my C:\Program Files\GPlates\GPlates 2.3.0\ match your C:\Users(my name)\Desktop\Art\…, in order to be fairly sure it’s not a DLL issue.

And are there any warnings/errors in GPlates_log.txt in your C:\Users(my name)\Desktop\Art\… directory, after GPlates has crashed?

Also I’m assuming that GPlates works for other tasks (such as opening the DataBundleForNovices.gproj project that is in the GPlates sample data)? I’m pretty sure it does since you mentioned having opened projects previously. Just want to make sure it’s not a fundamental problem to do with graphics hardware or something like that.

Most processes are:

I’m skipping over a bunch in the middle which use C:\Users(my name)\Desktop\Art\…
I’d say about 1/3 use C:\Users(my name)\Desktop\Art\… and most of the rest are C:\WINDOWS\system32 like you see in the second image. Only the 3 seen in the first image use C:\Program Files

I couldn’t find the DataBundleForNovices project, do I need to install that separately? But the one project I worked on was going completely fine until I encountered the issue. Tried fiddling around with the other tools a little and haven’t found anything else that didn’t work.

Thanks, your DLLs look good, so I don’t think that’s the problem.

Yes that’s in But it sounds like GPlates is generally working for you anyway, so I don’t think there’s a problem there.

By the way, I’ve just sent you a test build to try. There’s not much that ticking that Enable pole checkbox does, so I’ve disabled some rendering and added some debug output (as mentioned in the PM).