GPlates 2.3 for Window 64-bit crashed

Hello:

I have attempted to install GPlates 2.3 for Window 64-bit by using gplates_2.3.0_win64.exe downloaded from the EarthByte GPlates download website.

During the installation, there was no errors, but when I opened the GPlates application, I kept receiving the error message as shown below:

Log file created on Thu Nov 4 13:33:17 2021 by GPlates 2.3.0
[Critical] Failed to load libEGL (The specified module could not be found.)
[Warning] QWindowsEGLStaticContext::create: Failed to load and resolve libEGL functions
[Critical] Failed to load opengl32sw.dll (The specified module could not be found.)
[Warning] Failed to load and resolve WGL/OpenGL functions
[Critical] Failed to load libEGL (The specified module could not be found.)
[Warning] QWindowsEGLStaticContext::create: Failed to load and resolve libEGL functions
[Critical] Failed to load opengl32sw.dll (The specified module could not be found.)
[Warning] Failed to load and resolve WGL/OpenGL functions
[Critical] Failed to load libEGL (The specified module could not be found.)
[Warning] QWindowsEGLStaticContext::create: Failed to load and resolve libEGL functions
[Critical] Failed to load opengl32sw.dll (The specified module could not be found.)
[Warning] Failed to load and resolve WGL/OpenGL functions
[Critical] Failed to load libEGL (The specified module could not be found.)
[Warning] QWindowsEGLStaticContext::create: Failed to load and resolve libEGL functions
[Critical] Failed to load opengl32sw.dll (The specified module could not be found.)
[Warning] Failed to load and resolve WGL/OpenGL functions
[Critical] Failed to load libEGL (The specified module could not be found.)
[Warning] QWindowsEGLStaticContext::create: Failed to load and resolve libEGL functions
[Critical] Failed to load opengl32sw.dll (The specified module could not be found.)
[Warning] Failed to load and resolve WGL/OpenGL functions

Then, GPlates application just completely crashed. There was no response after.

May I ask for your help, please?

Hi Lavie,

It looks like you might need to install (or upgrade) your graphics drivers. Unlike macOS where the drivers are builtin, on Windows you need to install/upgrade the graphics driver yourself (eg, from Nvidia, AMD, Intel depending on what graphics you have).

Can you tell me what version of Windows you’re using (eg, 7, 8.1, 10)? I’m interested to know for the reasons below.

For reference, your error message surprises me because GPlates 2.3 requests that Qt use only desktop OpenGL (via the Qt::AA_UseDesktopOpenGL attribute), but your error message indicates that Qt is falling back to ANGLE and the OpenGL Software renderer library. This might be because Qt is first attempting to use desktop OpenGL but the drivers are not providing the minimum functionality (OpenGL 2.1) and so it decides to fallback to ANGLE anyway (even though GPlates has forced the usage of desktop OpenGL).

Hello John:

The Windows I am using is Windows 10, please.

Previously, I installed GPlates 2.2 and successfuly used it on the same computer. I am quite surprised since I never had issues with installing and using GPlates before.

Many thanks for taking time to examine the issue and provide me instructions. Looking forward to hearing from you.

Best,

Hi Lavie,

Thanks, so you’re not using an old Windows, that’s good.

Does GPlates 2.2 currently work? I see that it worked before but maybe something changed since then. If it also doesn’t work then my guess is the OpenGL drivers.