Error reading geometry when reading ESRI Shapefile to GPlates 2.3

Hello everyone:

When I read an ESRI Shapefile to GPlates 2.3, I received the error message as shown in the pictures attached to this message.

However, when I check the features from the shapefile in the QGIS program, I did not receive any error related to geometries or projection.

May I ask for your suggestions of how I can fix this error please?
Many thanks.

Hi Lavie,

this looks a bit like you’re having some CRS-related issues. What projection do you use in QGIS for your feature data? I sometimes have issues with “exotic” projections that are not part of the PROJ/GDAL system (ie not described at

Safest way is to make sure you use EPSG 4326 (Lon-lat, WGS84) in QGIS (for the feature data, not the QGIS project), check the geometries there and then import/open the features in GPlates. Maybe you can export the geometries (or of a single feature) to a text-based format (geojson, csv, OGR GMT) and visually inspect what feature geometry values are given as x,y coordinates.

Also, if you’re really stuck, it helps to post the data (or an example which causes the same issues) here.


Dear Christian:

Thank you for your response.

The map projection that I first used was ESRI:54009 - World Mollweide, and the second one was EPSG:4326. I believed both map projections were described in PROJ/GDAL system.

I tried to use both pygplates and GeoDataFrame to read the same shapefile and count the number of features. Below was the result that I got:

I also tried to reproject features in the shapefile to EPSG:4326 and loaded these features to GPlates, but I still got the same error message.

Hi Lavie,

at this time I can only speculate without an example of the data. Can you visually identify issues in the data set you use when you try and load the data in GPlates (GUI) and/or QGIS - are there features missing?

Again, I’d recommend to go through a workflow to convert/export the feature collection from any CRS to EPSG 4326 from QGIS as , as SHP/Geopackage or OGR_GMT file. Then load the exported file into GPlates and try to figure out which features cause trouble.

Running a simple check using awk filtering for the EPSG 4326 based data e.g. values > 360 (or < -180/ > 180) and > 90, < -90 that should point you in the right direction (of course you can also do the same for the World Mollweide using the permitted x-y ranges).

Cheers - Christian

Hi Lavie,

In addition to following Christian’s advice can you PM me a file that’s giving you that latest error message you posted (the one about gcs.csv) ? I just want to check that because we’ve fixed the latest GPlates and pyGPlates releases (ie, 2.3 and 0.36) to deal with that specific error (by including the required GDAL/PROJ data with GPlates/pyGPlates) so I’m a little surprised it’s still happening.

Hello to both Christian and John:

I am terribly sorry for my late response.

I figured the issue was I had geometries with incorrect coordinates.

Regarding the file that gives me the error message about gcs.csv, I will look for it again and ask my supervisor for permission to share with you.

Many thanks for your help.

Thanks for sending the file that gives the gcs.csv error message.

I believe the error is coming from software other than GPlates or pyGPlates. It looks like gcs.csv was incorporated into proj.db in GDAL version 2.5. And I’m not getting the error message in either GPlates 2.3 or pyGPlates 0.36 (both of which include proj.db via GDAL >= 2.5). You might be using something like shapely that’s using an older version of GDAL (< 2.5).