Newbie Question - rot files in MacOS

GPlates 2.3.0
MacBook Pro MacOS Catalina v 10.15.7

Hi all, I have a newbie question and please, if it’s been answered already, apologies, (and direct me to the response! :wink:

I am teaching myself this remarkable program, but am having problems generating a .rot file that GPlates will recognize. Specifically, I’ve been going through tutorial 2.4 Conducting a plate model from scratch. Tutorial 2.4 Constructing a Plate Model From Scratch

In this tutorial, you create a .rot file from provided data, save as a Tab separated document, and then, you hope, open it in GPlates.

Unfortunately, when I’ve completed the file, GPlates does not recognize the file as viable - it’s greyed out and unselectable in the selection window when I try to open feature collection.

I’ve experimented with the .rot files that are provided already complete in the tutorial to see if I can glean a difference between those (which GPlates will open) and the one I’ve created (which do not). I’ve experimented with removing the tabs in a text editor and replacing with spaces (as the provided files seem not to have tabs).

There is some text in the tutorial that notes that saving on a Mac can sometimes cause problems because of the CR/LF difference in the way Macs work vs. Windows machines, however, I cannot discern whether this is the problem in this instance.

I would be grateful for any assistance the community can provide.

Best regards,

David K

Hi David,

Double-check that the file extension is ‘.rot’.

GPlates only detects errors in the file after loading it. If it’s greyed out (on macOS) before you load it then it’s because GPlates doesn’t recognise it as a file type that it knows how to load (and this is determined by the file extension).

Hi John,

thanks for the suggestion. Here’s what the file name looks like:

Screen Shot 2022-03-16 at 7.56.07 AM


You can see they've got the suffix ".rot", but are greyed out. The bottom file, which is not greyed out and is selectable, is the file that came with the tutorial.

Best,

DK

Hi David,

The greyed out files might actually be ‘.txt’ files with the filename extension hidden (but just for .txt and not for .rot). And so filename.rot.txt looks like filename.rot.

You can check if this is the case by following this link (in the For one file section) and see if Hide extension box is checked. If this is the case then you can uncheck it.

On my mac just now I was able to load a (empty) file called RodiniaModel_Export.Experiment.dck.rot (ie, one of your greyed-out files).

Well, how about that! I have dealt with .txt files for years and macos still fooled me! Thank you so very much; I appreciate your help.

Changing the actual suffix does allow GPlates to recognize the file and load. There are some errors there, but I will see if I can figure them out.

thanks again and have a great day.

DK