Issue with Reconstructed Raster Not Filling in

Not sure exactly what is causing the issue, but I have one of three continents in this project that won’t fill in with the imported raster, and I cannot for the life of me figure out why.
I do have one other sort of anomaly in regards to this raster layer, which is some apparent clipping or doubling occurring on a separate continent - which I mention because I don’t know whether it’s related or not.

  • Inserted below is an assortment of different screenshots, which hopefully demonstrate the two issues adequately.

    (Apologies for any issues regarding legibility - I’m unable to insert more than one image into a post, so I had to condense them all into one.)
  • Note: The clipping occurring on Continent C only occurs in the 3D Orthographic view, and the issue with Continent A remains the same regardless of viewpoint used.

The image I used as a raster layer is a plain, green .png file, with dimensions of 3000px by 1500px
I have another raster layer for oceanic crust (Dimensions 1000px by 500px) and have had no issues with it whatsoever. Changing the size of the image that was imported seemingly made no difference.

Hopefully I’ve put this in the right category - was not sure whether this categorized as a bug, since this may be occurring due to user error.

Regardless, any help with this is greatly appreciated!

Figured I’d also include screenshots of the layer windows for both the land and oceanic crust as well, just in case.

I’ve also triple checked that each continent, its respective cratons, and crust are all filed and labeled correctly in the program - as far as I can tell, they’re all correct in this regard.

Hi @CactusKnight,

maybe a stupid question, but are your continent polygons real polygon geometries (ie closed loops) or line geometries (which are not closed)? I am asking as GPlates allows you to fill polylines and also allows you to select (poly-) line features in the raster layers to be selected as “Reconstructed Polygons”.

If your continent outlines are line features which you let fill by a raster, then GPlates will try and close them (as the raster clipping requires closed polygons). Depending on your geometry and rotations, this might cause continents not being filled or partly filled by the raster. I would expect this to happen esp in polar regions/high latitudes.

Test line geometries:

Test line geoms “filled” with ETOPO1 raster at 50% opacity and partly overlapping:

The different shading you get is because you have set transparency for the rasters, in overlapping regions, you will get the combination of two 50 or 35% opaque geometries (as per your settings above) overlying each other which make them appear as an area with a different color/opacity.

If this is the case one could argue that the UI is a bit misleading as the raster layer menu dialogue says “Reconstructed polygons” but allows you to use line geometries. So ideally GPlates should only use polygon geometries here (and not allow features with line geometries). However, this is a bit tricky as the GPML file format allows you to mix different geometry types (different to GIS files like SHP or GPKG which don’t allow this). It would mean that “Reconstructed polygons” should be changed to “Reconstructed geometries” in the UI. @John.Cannon might have a view on this.


Hi @chhei!

Unless I’m misunderstanding something, as far as I can tell, it’s a closed loop?
Image of the outline being selected:

The geometries were originally one large piece, which were then broken apart in the same way, so I’m not sure what would have changed, or how to check what’s off, otherwise.

You can check the geometry by highlighting the feature and pressing CTRL/CMD + R - For polygons it should say gml:exterior whereas line geometries should be gml:baseCurve:

To me this looks either like issues with the feature geometry - like I mentioned above - or stray features in your polygon file. I assume your original raster covers the whole planet/sphere? You can also check your polygon/continent file in QGIS by simply dragging and dropping the *.gpml file into the QGIS main window. This might help to debug what’s actually going on.

Again, the different shading usually is related to overlapping polygons/features with transparent raster images.


Okay, so, the geometry is definitely a closed polygon - I checked it like you described and it does indeed say gml:exterior
And yes - the original raster does cover the whole sphere.

I tried downloading QGIS as you suggested, but for some reason it was saying the *.gpml file was not supported…?
So I’m a little lost

Thank you for your help thus far!

I have. Fixed the problem somehow - no idea what it was but, oh well :joy:Probably inadvertently tidied of some wandering points geometry somewhere.

1 Like

Your original polygon might have been too large (ie, spanned more than 162 degrees) - see here. One way to test is to see if it can be filled (by enabling Fill polygons in its green layer). If it can be filled (as a solid colour) but not filled as a raster then it’s probably the 162 degree limitation.

Maybe it works now because it’s smaller than before?

It’s true than polylines can also be used. Although users are encouraged to use polygons (by stating Reconstructed polygons) since they are guaranteed to be a closed loop, whereas polylines can look like the following (where a single coastline boundary consists of multiple polyline segments)…

We probably should not allow polylines, but there are cases where users have polygons in polyline format and it would be a hassle for them to change it.