Extraction Error 0x80010135

Hi,

I was extracting files from the initial downloaded gplates-2.2.0-win64 zip folder and I received the error 0x80010135: path too long. This is stopping me from copying the file. It was for a .ROT file.

I received the error for quite a few similar files around 50% of the way through the extraction but skipped them. Do you think this will cause significant problems? Why would the path be too long?

Everything else in the extracted folder looks fine. Is there a manual anywhere for help running the program this way, without using the formal installation file? I tried that but my computer had problems afterwards - so I’m trying this way instead.

Thanks very much

Hi,

You are likely running into the Windows maximum path length limit. Maybe you are extracting to a directory that has a long path.You can try extracting to a directory with a shorter path (eg, "C:\Apps\" to start with).

The traditional path length limit in Windows is 260 characters, which is quite short. In our case this means the full extracted path of each file (including the filename and extension) must not exceed 260 characters. For example, if you extract to "C:\Apps\" then the rotation file (with the longest path) would be "C:\Apps\gplates-2.2.0-win64\SampleData\FeatureCollections\AlternativePlateReconstructions\PaleomagneticReferenceFrame\Matthews_etal_GPC_2016_410-0Ma_GK07_PMAG.rot" which is 162 characters (154 of which came from the zip file, which means the directory you were extracting to likely had a path length greater than 260-154=106 characters).

Also note that in Windows 10 (1607 and later) this limitation has been removed. But you must opt-in, which involves changing a registry entry as described here.

Regards,
John

Thanks very much, it’s running fine now.