Error: Missing GL version

Dear communauty,

I have a problem to open the last GPlates 2.3 on my Windows. It is an old computer with Windows 11.
It is impossible to install the new released because I’ve the following message:
Error: Missing GL version. I’m supposing it is a problem of openGL…
With the previous version I always installed the x32 version… It is possible to have this version??

Hi Paul,

Yes it’s an OpenGL problem. That error message (Error: Missing GL version) would happen when you run GPlates (after having installed it).

Does GPlates quit at that point? Because it can continue - it’s actually meant to be a warning.

It sounds like an older version of GPlates (but 32-bit, I guess you mean by x32, instead of 64-bit) worked on the same computer, is that correct? If so, was that Windows 10 or 11?

And can you tell me what model graphics hardware you currently have (when you ran GPlates 2.3)?

Dear John,

First, my Windows version is 10 (not 11, sorry).
GPlates doesn’t quit but it appears without the globe.
My old computer has both x86 (for 32-bits app) and x64. I uninstalled my last versions (2.0.0, 2.1.0, 2.2.0). All my previous versions were installed in the folder Programmes (x86). I already remarked that it was impossible to install the 64-bits version for the 2.2 version but it worked with the x32.exe so it was not a problem…
As the new version is only 64-bits, it now is impossible to install it for me.


Sorry for my previous emails…
I found the solution with my PC!!!
I had to go in my NVIDIA configuration, select the GPlates x64 and use high-performance processor for the GPlates and now it works…