Error and crash when attempting to open Scotese' paleomap

Hi all! I’m having trouble with a resource, Global_Scotese_PALEOMAP located in GeoData. Doesn’t work whether I try to open it as a project or as a feature collection (Map1a PALEOMAP PaleoAtlas). This is a fresh installation, too. I initially tried separately importing Scotese PaleoAtlas v3, which sometimes works, other times doesn’t, but opening it afterwards never works. Also, GPlates was initially installed in C:\Program Files\GPlates before I moved it to just C:\GPlates, sadly that didn’t solve the problem. Thanks in advance! Here’s the error:

Error: GPlates has caught an unhandled exception from " from event type 12: LogException: Error reading block data from raster file cache mipmap.
Call stack trace:
(C:\gplates\src\gplates-2.5.0\src\file-io\RasterFileCacheFormatReader.h, 494)

Hi Gwenilla,

It sounds like the raster .cache files got corrupted somehow. These files are created by GPlates when you first load the rasters (and then re-used on subsequent loads).

Try closing GPlates, then deleting the .cache files, then opening the project in GPlates again (to regenerate them).

Since you first opened the project/rasters using the GPlates installed in C:\Program Files\GPlates, the raster cache files should be in the Temp directory %USERPROFILE%\AppData\Local\Temp (you can just copy that path into the file explorer and it’ll take you there, and then you can delete them). The reason they’re in the Temp directory is C:\Program Files\GPlates is not writable.

Subsequently opening a copy of the project (and data files) - in your case in C:\GPlates - will still find the raster .cache files in the Temp directory. So you still have to delete any corrupt .cache files in the TEMP directory. Only if there are no .cache files in the Temp directory will GPlates then create them in the C:\GPlates directory (next to the actual raster files, like .jpg) because that directory is writable.

Thank you very much, for the quick reply as well! Worked like a charm :smiley: