Segmentation fault on Save As

Hi all,

I keep getting a segmentation fault whenever I try to save project files. If I click Save As in any of the menus or dialogs (e.g. Save Project As or in Manage Feature Collections), GPlates crashes with a segmentation fault. I can save existing projects and feature collections, but Save As or Save A Copy causes the program to crash.

I’ve rebuilt the application with debug symbols from the sources available on this thread and have run it through GDB a couple of times so I can provide stack traces if they would be useful.

My system is Arch Linux, using the following library versions:

  • GPlates 2.2
  • qt5 5.15
  • proj 6.3.2
  • python 3.9.1
  • gdal 3.0.4
  • cgal 4.14.3
  • qwt 6.1.6

Any ideas how I could get GPlates to work properly? I’m happy to compile and test different versions.

kind regards

Hi Robbie,

Thanks, yeah a stack trace would be great! And do you save to a folder where you have write permissions?


Hi John,

Here’s the stack trace. I couldn’t attach it directly because plain text files are not a permitted attachment type, and the full text was longer than the permitted character limit for replies.

GPlates doesn’t even bring up a dialog box for saving any files; it just crashes immediately upon clicking any ‘Save As’ buttons. This doesn’t seem to matter what directory I run the program from either. I’ve tried deleting the config files in ~/.config/GPlates in case there was something in that causing the issue, and got the same results.

kind regards,

Great, thanks for that!

I’ve uploaded a fix in the source code link you used (the link mentioned in this post). It’s the same download link but with updated source code. The only changed file is src/qt-widgets/ (so you can just replace that one file for a quicker build).

For others reading this, the bug happens on Linux only (including Ubuntu) but not on Windows or macOS.


Thanks John, that fixed the issue.